Memaksa PHP versi lama di cPanel

By | February 12, 2019

Memang PHP 5.6 telah saatnya ditinggalkan dan migrasi ke (minimal) PHP 7.0 bagi defaultnya. akan tetapi bagi blog yang tak ada masalah dapat ditunda dulu. akan tetapi saya baru tahu ada provider web hosting yang agresif sekali dan tanpa notifikasi tiba – tiba menjalankan upgrade ke PHP 7.0. 🙁

Alhasil forum phpBB milik klien saya seketika lumpuh seketika dan muncul error dimana – mana karena ada yang tak kompatibel. Ingin mengembalikan ke versi lama ternyata dari panelnya telah dihilangkan fiturnya.

Nah… saya hanya share 1 trik manual bagi memaksa menggunakan PHP 5.6 kembali, asalkan oleh providernya belum dihapus dan cuma disembunyikan dari tampilannya saja.

Silahkan menej file .htaccess dan tambahkan kode berikut didalamnya:


<IfModule mime_module>
AddType application/x-httpd-ea-php56 .php .php7 .phtml
</IfModule>

Setahu saya cara ini cuma dapat dimanfaatkan di cPanel.

akan tetapi harap ingat ini solusi sementara saja, coba cek apakah CMS atau script yang digunakan ada update bagi kompatibilitas PHP 7.0.


Sumber https://servernesia.com